AnsweredAssumed Answered

ST-LINK/V2 ISOL programmer/debugger issue on Nucleo 152RE

Question asked by sulik.daniel on Dec 29, 2014
Latest reply on Jan 12, 2015 by sulik.daniel
Hi,


I have spent some time on playing with this board and I am able to program it and debug it using the on-board st-link programmer. 
As we are planning to build a custom board based on STM32L152xE chip we wanted to access the STM32L152RE chip via  ST-LINK/V2 ISOL 
programmer/debugger. ( http://www.st.com/web/catalog/tools/FM146/CL1984/SC1046/SS1680/PF251168).
Following the nucleo board user manual I removed both jumpers from connector CN2, powered nucleo board from external 5V source, 
placed jumper to JP5:2-3 and wired up MCU VDD, SWDIO, SWDCLK, SWO, NRST and GND to the ST-LINK/V2 ISOL programmer.
Using STM32 ST-LINK Utility I am able to connect to the chip, read out the flash, chip ID, rev ID, etc. However, 
if I try to program the chip I am getting the following errors: 
Elf Loader could not be transfered to device.
Change 'Target/Settings/Connetion' mode to <<Connect Under Reset>> and Try again.
Can not connect to device!


ST-LINK/V2 ISOL programmer/debugger firmware version is V2J21S4 ( the latest from stm website). 
I have tried older versions with the same result.


Interestingly, I tried to access the Nucleo-RE board via STM32L-Discovery on-board 
st-link programmer and that one works OK without any issues. I can read and write the flash.


As we will be using  ST-LINK/V2 ISOL programmer/debugger for all development we need to get it working reliably.
Can anyone help? Your help is  highly appreciated. Ideally if anyone from ST can point me to the solution that 
would be great. It is either ST-LINK/V2 ISOL programmer issue or we are doing something wrong.


Thank you
Dan

Outcomes