AnsweredAssumed Answered

USB virtual comm port example on stm32f30/7 eval boards

Question asked by c.aodhan on Dec 15, 2014
Perhaps someone might be able to shed some light on this issue.

I am attempting to get the virtual com port demo up and running on my stm32f303C-Eval board. I am using the smt v4.0 USB full speed device driver (um0424). I have the demo working on an L1 board but I cannot get it working for the F3.

The first issue I had (which I have solved) is that the USB connect/disconnect interrupt handler wasn't firing when I plugged in a USB cable on the F3 board. I solved this by adding a 1.5k pull up resistor to the PA12 pin, pulling it up to 3.3v. It seems there isn't any default hardware pull up resistors on the F3 board. 

Now when I plug in the USB cable to the eval board (and PC) a hardware change is detected in my hardware device drivers (windows 7), but it comes up as an unknown device, not an STMMicroelectronic Virtual COM Port (COMX) as it should.

Any thoughts? Are there other hardware configurations I need to implement to get this working?

Outcomes