AnsweredAssumed Answered

STM32F4DISCOVERY, can't seem to run anything

Question asked by Esa Varemo on May 26, 2014
Latest reply on May 28, 2014 by Esa Varemo
I have a F4 discovery board, which I am trying to run a simple led-blinker on. I've tried the demo .hex, demo IO_Togglek, Blinky from Keil and one other simple demo.

I have used precompiled/built with GCC or Keil. 

I can program and verify the memory contents with the integrated St-link v2 from either Keil µVision or the ST-Link Utility. However I can't seem to get it to run the code properly.

I have tried single-stepping in µVision, which seems to get stuck on random instructions, go to a hard fault or jump to a random address that seems to be after the end of the actual disassembly shown
(like: 0x008C0190 0000      MOVS          r0,r0, where the actual disassembly seems to end around 0x00010000.) This is accompanied by "Cannot access memory" (outside the bounds?)

Do I have a faulty board or is there something obvious that I'm doing wrong?

Outcomes