AnsweredAssumed Answered

Bug Repport: CubeMX 4.16.0 DMA "Use FIFO" Checkbox stuck

Question asked by yarema.andriy on Aug 10, 2016
Latest reply on Aug 12, 2016 by Nesrine M
Using CubeMX version 4.16.0 with DMA it does not let you turn off FIFO mode. The check mark does not deselect. 
FifoError.PNG

The generated source code needs to be manually modified to turn off FIFO. After the following change the DMA works properly.
DMAFix.PNG


Attachments

Outcomes