AnsweredAssumed Answered

Did I just brick my evaluation board?

Question asked by spitaels.joeri on Dec 17, 2013
Latest reply on Jun 29, 2015 by rortveit.oyvind
Hello,
I bought a STEVAL-MKI109v1  evaluation board, and a STEVAL-MKI114v1 probe about 1,5 years ago.
Yesterday I tried to get it to work with the latest version of the Unico test software, but the program would always hang as soon as I clicked on anything that would read data from the sensor. So I figured I needed to upgrade the firmware.
In the Unico manual, it said that the Dfu firmware updater on the eval board needed upgrading first, before the firmware v3 properly said could be installed. So I uploaded the Dfu firmware that came with that latest version of Unico onto the evaluation board.
In order to update the firmware, the device needs to be put in Dfu mode, by holding a button while powering it up, so I did that.
However, the updater warned me that I could not back up the old firmware, nor verify whether the new firmware is correct, precisely because the device was in dfu mode. Now there's an obvious catch 22 because the updater will only run in dfu mode.
Nevertheless, the dfu firmware update went ok as far as I could tell.
Next I tried to uploaded the eMotion v2 firmware. I have a v1 device, but could not find any v1 firmware, so I assumed the v2 would cover both versions of the device.
Now the problem is that after having erased the old firmware at 92% the process stalled. I waited a bit, and then decided to reset and power cycle the device, knowing that would cause trouble, but I didn't see much of another way out of the situation.
So now the device is completely dead, even the power led will no longer light up.
Did I brick it, or is there a way to resuscitate it, and if so how and with which firmware?
Thank you for any advice.

Outcomes