AnsweredAssumed Answered

Suddenly - ST-Link Has Stopped Working !

Question asked by roofie01 on Jun 26, 2016
Latest reply on Jun 27, 2016 by roofie01
I have a problem here that doesn't make one shred of sense. I have boards (STm32F405VG) I programmed a couple months back that were fine. Meaning, I could connect to the board, and print the output statements from the code when I used the ST-Link's "Print from SWO Viewer" function.
Suddenly it is not working. All settings are correct including port, frequency, etc. When I use the "Print from SWO Viewer" and then "Start", it disconnects from the target! I get the pop-up dialogue box stating "Disconnected  from SWV Trace Port".  This comes up in the main panel message box:

09:42:17 : Connection to device is lost: check power supply and debug connection.
09:42:17 : If the target is in low power mode, please enable "Debug in Low Power mode" option from Target->settings menu.
09:42:17 : Disconnected from SWV Trace port!


Tried different settings that did not help. Which I should not even bother because I have never needed to change settings with these boards, it's always worked. I've also tried on three different boards and they are all behaving the same. I went as far as trying the newest version of ST-Link utility and that didn't help at all.

What in the world could be going on? It makes little sense. I know it cannot be the target boards - maybe one might give a problem , but not three....and all behaving exactly the same.

Any help would be greatly appreciated.


Outcomes