AnsweredAssumed Answered

ST-Link Utility can't program OTP memory

Question asked by ltay on May 24, 2016
Latest reply on May 27, 2016 by FTITI.Walid
Hi all,

We can't seem to program any memory in the OTP memory range on the F7 series (STM32F746VG). We are trying to program in the address range of 0x1FF0F000 onwards.

When we do we get an error "Error occured during memory writing!".

I have contacted ST support with no response in 2 weeks, is that normal?

In the past we have also had a bug like this which ST ended up confirming was in their current software. We had to use an old version of the software until they fixed it as a workaround. That was on the F4 range. Now we can't find any working version for programming OTP in the F7 range.

I've tried ST-Link Utility V3.5, V3.8 and V3.9 all with the same problem, as well as several physical chips and different programmers, all with the latest firmware.

Would be very interested to know if anyone else is having similar problems or can program it OK?

Outcomes