AnsweredAssumed Answered

CubeMX problem....

Question asked by reed.matthew.003 on May 20, 2016
Latest reply on May 23, 2016 by FTITI.Walid
I'm using the wakeup interrupt from the RTC, but I don't want it active until certain conditions are present.

But I have no choice, either I disable it in Cube and get no stubs for interrupts and no definition, or I enable it and it is automatically running, like it or not.

Fortunately I've found that is won't actually start until I do:
__HAL_RTC_WAKEUPTIMER_CLEAR_FLAG(&hrtc, RTC_FLAG_WUTF);

Is that by design? If so why isn't it in the HAL documents?

I would suggest having a check-box in the configuration of 'enabled'.  So it can be configured in a disabled state.

-Matt

Outcomes