AnsweredAssumed Answered

STM32L Discovery USB

Question asked by plankar.jernej on Sep 6, 2013
Latest reply on Sep 9, 2013 by plankar.jernej
Hi,

first of all, I'm writing a new thread because I couldnt reply to [DEAD LINK /public/STe2ecommunities/mcu/Lists/STM32LDiscovery/Flat.aspx?RootFolder=/public/STe2ecommunities/mcu/Lists/STM32LDiscovery/STM32L%20Discovery%20and%20STM32F10x%20and%20STM32L1xx%20USB-FS-Device%20Library&FolderCTID=0x01200200770978C69A1141439FE559EB459D758000BA7000AD27065745A5C15A65B5BEF01F&TopicsView=https://my.st.com/public/STe2ecommunities/mcu/Lists/STM32LDiscovery/AllItems.aspx&currentviews=1333]this  debate (why do I get "You are not authorised to view this page." error if I click "Reply"??).

Anyway, i'm trying to get STM32L on DIscovery board to communicate via USB to a PC. I have been doing this for a long time and it seems a lot of developers are having a hard time. So, to start, i tried to realize the above project from m.e (VirtualCOM), PC detected the unknown device, but nothing further. So i followed m.e's hardware steps soldering SB17. The device is still only detected and it does nothing (drivers do not install), but the big issue is that now no compiler can connect to the device, so i cant even debug or anything. I tried to connect with ST Link utility, but i always get "Internal command error" to whatever action. However,  I can upgrade the device firmware with this app.

So, what did i do wrong and how can i "repair" things? And, BTW, what is the purpose of the MCO pin?

Thank you

Outcomes