AnsweredAssumed Answered

Bug in STLink - OSX

Question asked by ChrisH on Feb 23, 2016
Latest reply on Feb 23, 2016 by ChrisH
Unfortunately new STLink update bricked 3 of my boards (in terms of usability under OS X) again the issue is with libusb. Now I can't downgrade this firmware cause you cant find any older versions on the website. Apparently release notes mentioned sth about fixing problems with OS X well turns out there are new ones (old ones).  I'm on fresh 10.11.4

Verbose output from terminal:

libusb_handle_events() timeout
[!] send_recv
2016-02-23T05:31:00 DEBUG src/stlink-common.c: stlink mode: unknown!
libusb_handle_events() timeout
[!] send_recv
2016-02-23T05:31:03 DEBUG src/stlink-common.c: stlink mode: unknown!
2016-02-23T05:31:03 DEBUG src/stlink-common.c: *** stlink_enter_swd_mode ***
libusb_submit_transfer(-6)
[!] send_recv
2016-02-23T05:31:03 DEBUG src/stlink-common.c: *** looking up stlink version
libusb_submit_transfer(-6)
[!] send_recv
2016-02-23T05:31:03 DEBUG src/stlink-common.c: st vid         = 0x0000 (expect 0x0483)
2016-02-23T05:31:03 DEBUG src/stlink-common.c: stlink pid     = 0x0000
2016-02-23T05:31:03 DEBUG src/stlink-common.c: stlink version = 0x0
2016-02-23T05:31:03 DEBUG src/stlink-common.c: jtag version   = 0x0
2016-02-23T05:31:03 DEBUG src/stlink-common.c: swim version   = 0x0
2016-02-23T05:31:03 DEBUG src/stlink-common.c:     notice: the firmware doesn't support a jtag/swd interface
2016-02-23T05:31:03 DEBUG src/stlink-common.c:     notice: the firmware doesn't support a swim interface
2016-02-23T05:31:03 INFO src/stlink-common.c: Loading device parameters....
2016-02-23T05:31:03 DEBUG src/stlink-common.c: *** stlink_core_id ***
libusb_submit_transfer(-6)
[!] send_recv
2016-02-23T05:31:03 DEBUG src/stlink-common.c: core_id = 0x00000000
libusb_submit_transfer(-6)
[!] send_recv
2016-02-23T05:31:03 DEBUG src/stlink-common.c: *** stlink_read_debug32 0 is 0xe0042000
libusb_submit_transfer(-6)
[!] send_recv
2016-02-23T05:31:03 DEBUG src/stlink-common.c: *** stlink_read_debug32 0 is 0x40015800
2016-02-23T05:31:03 WARN src/stlink-common.c: unknown chip id! 0
2016-02-23T05:31:03 DEBUG src/stlink-common.c: *** stlink_close ***
Segmentation fault: 11

Outcomes