AnsweredAssumed Answered

LPS25hb not able to read correct pressure or temperature values

Question asked by wittinger.eric on Aug 5, 2016
Hi All,

I am working with a LPS25HB sensor and am not able to get valid data out for the pressure or Temperature. 
Here is a register dump of my settings (tried 2 different settings):
LPS25HB reg dump:
0x08 , 0x0B
0x09 , 0xA8
0x0A , 0x3F
0x0F , 0xBD
0x10 , 0x05
0x20 , 0x90
0x21 , 0x00
0x22 , 0x00
0x23 , 0x00
0x24 , 0x00
0x25 , 0x00
0x27 , 0x33
0x2E , 0xCF
0x2F , 0x20
0x30 , 0x00
0x31 , 0x00
0x39 , 0x00
0x3A , 0x00

LPS25HB reg dump:
0x08 , 0xF0
0x09 , 0xA8
0x0A , 0x3F
0x0F , 0xBD
0x10 , 0x05
0x20 , 0xA4
0x21 , 0x00
0x22 , 0x00
0x23 , 0x00
0x24 , 0x00
0x25 , 0x00
0x27 , 0x33
0x2E , 0xCF
0x2F , 0x20
0x30 , 0x00
0x31 , 0x00
0x39 , 0x00
0x3A , 0x00

Here is the data I am getting out for the pressure sensor: 
<LPS25HB> Pressure = 0 hPa
<LPS25HB> PRESS_OUT_XL = 248
<LPS25HB> PRESS_OUT_L = 255
<LPS25HB> PRESS_OUT_H = 255
<LPS25HB> RPDS_L = 0
<LPS25HB> RPDS_H = 0


<LPS25HB> Pressure = 0 hPa
<LPS25HB> PRESS_OUT_XL = 64
<LPS25HB> PRESS_OUT_L = 0
<LPS25HB> PRESS_OUT_H = 0

<LPS25HB> Pressure = 0 hPa
<LPS25HB> PRESS_OUT_XL = 226
<LPS25HB> PRESS_OUT_L = 1
<LPS25HB> PRESS_OUT_H = 0

<LPS25HB> Pressure = 0 hPa
<LPS25HB> PRESS_OUT_XL = 71
<LPS25HB> PRESS_OUT_L = 1
<LPS25HB> PRESS_OUT_H = 0

<LPS25HB> Pressure = 0 hPa
<LPS25HB> PRESS_OUT_XL = 214
<LPS25HB> PRESS_OUT_L = 0
<LPS25HB> PRESS_OUT_H = 0

<LPS25HB> Pressure = 0 hPa
<LPS25HB> PRESS_OUT_XL = 98
<LPS25HB> PRESS_OUT_L = 1
<LPS25HB> PRESS_OUT_H = 0

<LPS25HB> Pressure = 0 hPa
<LPS25HB> PRESS_OUT_XL = 191
<LPS25HB> PRESS_OUT_L = 0
<LPS25HB> PRESS_OUT_H = 0

<LPS25HB> Pressure = 0 hPa
<LPS25HB> PRESS_OUT_XL = 139
<LPS25HB> PRESS_OUT_L = 1
<LPS25HB> PRESS_OUT_H = 0

<LPS25HB> Pressure = 0 hPa
<LPS25HB> PRESS_OUT_XL = 6
<LPS25HB> PRESS_OUT_L = 254
<LPS25HB> PRESS_OUT_H = 255

<LPS25HB> Pressure = 0 hPa
<LPS25HB> PRESS_OUT_XL = 16
<LPS25HB> PRESS_OUT_L = 255
<LPS25HB> PRESS_OUT_H = 255

<LPS25HB> Pressure = 0 hPa
<LPS25HB> PRESS_OUT_XL = 200
<LPS25HB> PRESS_OUT_L = 254
<LPS25HB> PRESS_OUT_H = 255

<LPS25HB> Pressure = 0 hPa
<LPS25HB> PRESS_OUT_XL = 28
<LPS25HB> PRESS_OUT_L = 254
<LPS25HB> PRESS_OUT_H = 255

Any thoughts or suggestions on what I might be doing wrong, or have setup incorrectly.

Thanks,
Eric

Outcomes