AnsweredAssumed Answered

STM32CubeMX STM32F0xx_StdPeriph_Lib_V1.5.0 This package Version is not managed

Question asked by kaminski.gregorio on Oct 28, 2015
Latest reply on Oct 30, 2015 by Clive One

The package version is not managed on this version of STM32CubeMX
stm32f0_stdperiph_lib.zip -> STM32F0xx_StdPeriph_Lib_V1.5.0
Firmware package STM32F0xx_StdPeriph_Lib_V1.5.0 and STM32CubeMX 4.11.0 - Error happens

Hello,

When I started a library install on Help->Install New Libraries->From Loc (STM32CubeMX 4.11.0 ..and 4.10. too/same situation) at the end of  the "unzip"/install process,
occur an error: The package version is not managed on this version of STM32CubeMX

I would like install/update to STM32F0xx_StdPeriph_Lib_V1.5.0
(I have freezing problems on HAL_UART_Receive_IT, eventually this new library will be solving..)
the STM32F0xx_StdPeriph_Lib_V1.3.0 is installed in the STM32CubeMX 4.11.0.
 
On the STM32CubeMX I saw that only the STM32F0xx standard peripherals library 1.4.0 version was on list.
Where is this file/1.4.0 version to download on ST/Site?
What's going on STM32CubeMX 4.11.0 and STM32F0xx_StdPeriph_Lib_V1.5.0 due these files were fresh downloaded from ST/Links?
Help, please ..!

STM32CubeMX 4.11.0
http://www.st.com/web/catalog/tools/FM147/CL1794/SC961/SS1533/PF259242?sc=stm32cube
http://www.st.com/web/catalog/tools/FM147/CL1794/SC961/SS1533/PF259242?sc=stm32cube#

stm32f0_stdperiph_lib.zip -> STM32F0xx_StdPeriph_Lib_V1.5.0
http://www.st.com/web/catalog/tools/FM147/CL1794/SC961/SS1743/LN1939/PF257884
http://www.st.com/web/catalog/tools/FM147/CL1794/SC961/SS1743/LN1939/PF257884#
 

Outcomes