AnsweredAssumed Answered

Broken STM32F4 Discovery demonstration...no mouse!

Question asked by SparkBuzz on Mar 24, 2013
Latest reply on Mar 24, 2013 by SparkBuzz

I quite enthusiastically purchased an STM32F4 Discovery quite recently, and when I initially unboxed the board, I hooked it up to my Mac, and the already programmed in demonstration was working 100%.

I was able to view the flashing LEDs, and when pressing the user button, the accelerometer would act as a mouse pointer controller, moving the mouse pointer about on the screen as I tilted the board. That was awesome!

I used Texane ST-Link and the Sourcery Codebench Lite toolchain on Mac OS X 10.8 to compile a few other examples, nothing serious, just basic blinky stuff, and everything was working fine when flashing the board.

It took me a couple of weeks to get Eclipse CDT setup with the CodeBench toolchain, it's quite a tedious process, but at least I'm compiling without errors now.

I downloaded the samples from ST.com trying to compile the original Demonstration from the STM32F4 Discovery board page. The project compiled without errors, and when I flashed the board with the compiled binary, everything seemed to work fine.

The LED blinking bit works okay, and when I press the user button, once again, the board goes into the accelerometer mode. The lights are flashing as the board is tilted, but this time the mouse pointer interaction stopped, the mouse pointer is not moving at all. 

I tried checking if my USB cable was borked, tried a different cable, and I also tried another machine, but no matter what I tried, I couldn't get the board to work as a USB device using the original demo. The green LED next to the CN5 connector is coming on, indicating power, and I even tested with a multimeter, it's a good 5V+.

Is there some way I can get the original .elf files to flash the board, to see at least if it works in the way it comes out of the box. I'm guessing if I can ask whether I can reset the board to factory standard, with the original demonstration. This way I can eliminate the possibility of whether the USB pins on the board might have blown or something is wrong with my toolchain.

I have created a project on Github where I've setup the demonstration project to compile with Eclipse Juno CDT, the GNU ARM Eclipse plugin, Sourcery Codebench Lite, see the readme for more details.

I also added my precompiled .elf file, and was hoping maybe someone could flash their Discovery and see if the example works with mouse pointer moving on the accelerometer.

Outcomes