AnsweredAssumed Answered

STM32F3Discovery, replaced MCU with STM32F407VGT6

Question asked by bader.eric.003 on Mar 21, 2013
Latest reply on Mar 21, 2013 by fm
Hi,
I have a STM32F3Discovery eval. board which I used to build an IMU controlled by a computer through Graphical User Interface. This is an excellent board (9 Degrees of Freedom) and it is a good way to start.
I have been curious about the Micro Framework from Microsoft but it requires at least 64KB of RAM.
However the STM32F3 has only 48KB. Therefore, I decided to replace the current MCU with one that can fit the Micro Framework. I picked the STM32F407VGT6 for many reasons. One important reason is that it is entirely pin-compatible.
I tried to download a demonstration code of the STM32F407VGT6 and I got a message telling:
Fatal error: ST-Link, No MCU device found   Session aborted! 
Failed to load flash loader
Things worked fine before I replaced the micro. 
The datasheet of the evaluation board says that the ST-Link can program any STM32 micro, so my change should work, right? What is the reason of the message?
I am using IAR 6.50.1.4452 for ARM.

Outcomes