cancel
Showing results for 
Search instead for 
Did you mean: 

STM32CubeProgrammer rocky8 linux launch issue

re24
Associate

After Install launching returns CubeProgrammer_API is missing. Please try reinstalling or check you java architecture. Ive seen some other forum posts with this issue and tried to fix the java version to no avail.

Current java version is java-1.8.0-openjdk.x86_64

Ive also tried a liberica version  bellsoft-java8-full.x86_64

console output of error, I can see the files that were failed to load in the file system so I believe it was installed properly

Native code library failed to load:
java.lang.UnsatisfiedLinkError: Unable to load library '/home/eastwor/STMicroelectronics/STM32Cube/STM32CubeProgrammer/bin/../lib/libCubeProgrammer_API.so': Native library (home/eastwor/STMicroelectronics/STM32Cube/STM32CubeProgrammer/bin/../lib/libCubeProgrammer_API.so) not found in resource path ([file:/home/eastwor/STMicroelectronics/STM32Cube/STM32CubeProgrammer/bin/STM32CubeProgrammerLauncher])

 System I'm running on is rocky8 Linux x86_64

1 ACCEPTED SOLUTION

Accepted Solutions
re24
Associate

Downloading an older version worked, using 2.9

Error occurred with latest version 2.16

View solution in original post

1 REPLY 1
re24
Associate

Downloading an older version worked, using 2.9

Error occurred with latest version 2.16