cancel
Showing results for 
Search instead for 
Did you mean: 

when I copied project and rename it, the debug still debugs the copied source files, not the new one

demir
Senior II

Hi,

I have created a project by simply performing copy and paste. I copied 002LED_Tasks and pasted onto project explorer, then rename it as 004LED_Periodic_Tasks.

When I debug the 004LED_Periodic_Tasks, debugger debugs the 002LED_Tasks.

Please find attached images.

problem1.png

problem2.png

  

Could you please point me to the right direction in which I can resolve this problem ?

7 REPLIES 7
AScha.3
Principal III

Hi,

Just look in your debug configuration -> settings, what file is used for debug (and change it...):

AScha3_0-1709040909084.png

 

If you feel a post has answered your question, please click "Accept as Solution".
demir
Senior II

seems like problem is not about that, please see below. What could be the root cause ?

problem3.png

Hmmmm.....if you use openOcd, there is another path -> script file to change:

AScha3_0-1709042707091.png

 

If you feel a post has answered your question, please click "Accept as Solution".
demir
Senior II

No I didnt use open OCD. I suspect it is about the makefile. 

problem4.png

....and i debug setting main :  correct elf file ?

AScha3_0-1709046816971.png

 

If you feel a post has answered your question, please click "Accept as Solution".

Unfortunately elf file is correct.

 

demir_1-1709049234390.png

 

I believe, there is something causing these files to be generated under Debug folder. What could it be ? any idea ?

demir_0-1709049203059.png

 

demir
Senior II

@Tesla DeLorean and @Pavel A. could you please check this for me ?

Thank you.