Showing results for 
Search instead for 
Did you mean: 

myStm login does not work

Associate II

I cannot login in the STM32CubeIDE V1.15.1, it keeps falling, I have a plain private internet connection without any additional firewall than the one there is on my computer. I do not use vpn.
Everything else Works fine on the internet

i have also tried to disable my firewall, still no luck, Have also tried hotspot on my phone, no difference
I have tried all three network settings under the preferences.

I can login in the browser, but I cannot download the software for reinstall, everytime it keeps prompting me for login into stm again, even that I already is logged in.

I have tried to restart my computer several time.

On my computer at my workspace it works at it should.


Accepted Solutions
ST Employee

Dear @Kvang ,

Original issue solved by 17th May 2024  The CubeMX/CubeIDE login issue is resolved - STMicroelectronics Community.



View solution in original post

Associate II

Need to login to update the HAL libraries...Need to login to update the HAL libraries...Any minute now...Any minute now...And... fail. Again.And... fail. Again.

Billy OWEN
ST Employee

Hi @Kvang 


This post has been escalated to the ST Online Support Team for additional assistance.  We'll contact you directly.





I'm also having the same issue.

Associate II

I am also completely out of commision due to this error. 

With respect, there are more of us than just Kvang with this problem. This is impeding our ability to do any work here. Thanks.

Associate II

same issue for 2 days now, for un unnecesssary lock. why having to log Cube ??? If it cannot log, let it run.

Associate II

I'm still down... I can log in through the web site, but the CubeIDE (1.15.1) will not log in. It hangs and says the network is down. I have no proxy, VPN, or firewall blocks. I am working on a new design and can't generate code from the ioc file if not logged in. I would strongly recommend making login optional for critical tasks and just keep retrying in the background.

NOTE: I had another system that was logging in on its own at startup just fine. I stupily logged out to see if the problem was machine specific and now that system won't log in either.

UPDATE: Can confirm the error occurs on both Linux and Windows versions. It seems to be on the Server side.


Same issue here.

Huge bummer having just picked up an STM board for the first time...

Associate II

workaround: install CubeIDE 1.12.1

It has no login functionnality and use latest packages.

if Cube MX is not conveniant, you can open your IOC file in a text writer and change this line


to your version.