Showing results for 
Search instead for 
Did you mean: 

Unable to connect to AP using the hotstap service

Associate II


I am compiling a yocto custom layer, I am using this layers

poky/meta-poky \
poky/meta-yocto-bsp \
meta-openembedded/meta-oe \
meta-openembedded/meta-python \
meta-st-stm32mp \
custom-image \

I was able to connect the LBEE5KL1DX Murata module to wifi via STA, however, I would like to use switch to the AP mode, I followed the steps in the post


After that, i am able to see the AP when I look in a smartphone, but after logging with the password configured, I see the message "IP configuration failure " on my smartphone.

One thing I see suspicious is the inet when i run the command "ifconfig"

Screenshot from 2023-08-23 17-37-40.png

Another thing i see weird is when i run the "networkctl status wlan0" command, specifically the Network File variable


Screenshot from 2023-08-23 17-40-13.png

I also tried executing the bash script from a repository and it didn't work either


Any help is very appreciated, thank you,


ST Employee

Hi @obedPH ,

Could you please explains you full setup by what you call AP ? 

eg is it like : Smartphone (hotpost wifi) < wlan > MP15 <eth> PC or something else ? 

Please also confirm the ecosystem you are using and provide content of /lib/systemd/network/  and /lib/systemd/network/



In order to give better visibility on the answered topics, please click on 'Accept as Solution' on the reply which solved your issue or answered your question.
Associate II

Hello @Olivier GALLIEN,

Thank you for your response and willingness to assist. I'd like to provide you with more details about my setup and the issue I'm experiencing:

  1. Configuration: I am attempting to connect other devices, such as my smartphone and PC, wirelessly to a Wi-Fi network generated by the STM32MP157F-DK2. My current setup looks like this:

    • Smartphone (Wi-Fi hotspot) <-> [Wireless Connection] <-> STM32MP157F-DK2 (Access Point). I want just to be able to connect to the Access Point, since I want to open a webserver, and then, in the webserver in certain port, I want to write the SSID and PASSWORD credentials of another Wifi network (this network has the internet connection), basically, I want to setup my wifi credentials in a webserver, that's why I need my STMPU working as an Access Point.
  2. Access Point (AP): I am configuring the STM32MP157F-DK2 to function as an Access Point, allowing other devices to connect to it wirelessly.

  3. Environment: I am using yocto with the 5.15.67 kernel version in my development environment.

  4. This is the content of my /lib/systemd/network/51-wireless.networkobedPH_0-1693935610318.png
  5. This is the content of my /lib/systemd/network/ obedPH_1-1693935688706.png

    Thank you very much, regards