Showing results for 
Search instead for 
Did you mean: 

In-Sensor Data Processing: MEMS with ISPU Core workshop - I'm getting "X-CUBE-ISPU: NOT INSTALLED"

Associate II

I installed it twice in Windows 10 from the zip file I downloaded from the ST website and then once with GitHub, but still no joy.

All the other apps show up as Ok by the Validator.

I'm going to proceed with the workshop but if you can shed some light on why I'm getting this message, I'd appreciate it.

Regarding my configuration, I've install the executables in "f:\usr" vs "c:\program files" and the data in g:\wss" vs.  "c:" drives.

ST Employee

Hello @pinaar ,

Did you try installation using STM32CubeMx?

From the "Embedded Software Packages Manager" window, press the [Refresh] button to get an updated list of add-on packs. Go to [STMicroelectronics] Tab, and select the [X-CUBE-ISPU] package version you wish to install and click the [Install] button.


When your question is answered, please close this topic by clicking "Accept as Solution".

Thank you so much. I just installed STM32CubeMx and installed the X-CUBE-ISPU from the "Embedded Software Packages Manager". Since the workshop is on MEMS with ISPU Core, I also installed the MEMS1 Software Package.

I ran the validator and it still says the X-CUBE-ISPU is not installed, but I'm not concerned since I now have access to it from the STM32CubeMx, so I should be able to continue the self-paced workshop and use the STM32CubeMx when I need the X-CUBE-ISPU. (I attended the workshop without the NUCLEO-L476RG because I had to order it from Amazon vs. the ST Store, so I didn't get it until the day after the workshop when I was on travel, so I am only now resuming the workshop with all the necessary hardware and software installed on my Windows 10 server. I also have some software on my Ubuntu server which I'll use after the workshop for new designs and software development.)