Showing results for 
Search instead for 
Did you mean: 

STMH743XI-E02 fails to validate NN model on target. LOAD ERROR: STM32 - no connected board(s), invalid firmware or the board should be re-started.

Associate II

Hi, I am trying to deploy a Keras model that fits in the board STMH743XI-E02. In order to do so, I've created the model, and loaded it into the project according to the current documentation.

I've tried to use several USART ports to enable communications with the board, and I've tested the USART communications with an example project that correctly send the data to my terminal. Meaning, that my configuration is correct, at least on the board to use the USART.

But when it comes to use STM32CUBEMX and the AI additional package, after analyzing the model, and validate it on desktop, the following error appears to me, once and again:

LOAD ERROR: STM32 - no connected board(s), invalid firmware or the board should be re-started

  • My last configuration usses USART1 Asynchronous for communications. I'be tried with pins:
    • PB14, PB15
    • PA9, PA10
    • PD8, PD9 (USART3)
  • I've used the validation template on the AI package.
  • The clock is set to 480MHz on the Clock configuration tab.
  • Minimmum Stack size to 0x2000 on the Project Manager tab.
  • The model fits without compression, occuping:
    • 324.78 KBytes Flash
    • 9.37 KBytes RAM
    • 290840 MACC
  • I have my own validation data inputs and outputs and on desktop they work ok.
  • I'm using the latests version of the tools.

My questions are:

  1. Do I need to perform further configuration to generate the code?
  2. What actions do I need to perform to be able to validate the model on target using the UI? Any option to achieve this stage without UI?

Attached, project.ioc, the STMCUBEMX project and the model I've used along with the validation data.

Thank you very much for your time.


Thank you for your time Daniel.

I am using the exact same versions, and steps as you do, and still the same error.

Is it possible that there is a defect on my board? If so, how to spot it?

This is the project I'm using,

if it is not working it seems that the USART1 is not sent to the ST-Link correctly.

You said in an earlier post that with another program you saw something on the STLink Virtual Com Port, so I assume that the jumper configuration is correct.

Associate II

I tried to load your project and same results. Here is the project that does work with UART:

I attached it here in case I am missing something. Also attached, board jumpers and back of the board with the reference number.

Regarding the drivers I am using Windows10. And I've installed both link009 and updated with link007.

ST Employee

the difference between the 2 projects is the configuration of the pullup and port speed.

You can try to change in the stm32h7xx_hal_msp.c those 2 parameters to the values below:

 GPIO_InitStruct.Pull   = GPIO_PULLUP;


Hi, I've tried that too, and nothing different happens. I believe that the two projects are generated very differently.

Having the same issue with the B-L475E-IOT01A Discovery kit.

(I'm newbie and still learning.)



I'm having the same trouble with STM32F407 discovery board... any suggestions ?

I'm using x-cube-AI 5.0.0 version