Showing results for 
Search instead for 
Did you mean: 

Problems with X-CUBE-AI, printf(), and default configuration on Nucleo F746ZG and CubeIDE 1.8.0, Windows 10 64bit.

Associate II

After installing the latest version of CubeIDE, there was a problem with the Nucleo F746ZG projects. It turned out that the default configuration of peripherals (especially ethernet) causes errors. The printf function worked badly (e.g. it could not cope with the delay function), and after using the X-CUBE-AI plugin, it stopped working at all. Only installing older versions fixed these problems (CubeIDE 1.0.2; CubeMX 5.3.0; MCU F7 1.15.0; X-CUBE-AI 5.1.2). Are you also having problems with the new versions, or am I doing something wrong? I don't know how the intermediate versions behave, previously I used Eclipse in CubeMX and SW4STM32 plugins and everything worked.

mattias norlander
ST Employee

Do you have a minimal project which re-produces the issue?

I don't know how to check this really.

Could you also state what you mean with:

"The printf function worked badly (e.g. it could not cope with the delay function)"

Is this a bare-metal application or relying on an RTOS?

Associate II

I uninstalled this version of CubeIDE and I don't know if I have a project somewhere else that didn't work for me.

If I had printf and HAL_Delay in the while function, the serial port "spat out" the text as if in chunks. For example, it sent nothing for several seconds, and then several dozen lines at once. Even though it should send 1 line, wait 0.5s and send another line.

On the other hand, the mere inclusion of X-CUBE-AI in the CubeMX project completely prevented me from sending anything via printf, even though the debugger showed no errors. Exactly the same code (I only modified the main.c and app_x-cube-ai.c files, I did not check the others) with the same settings of clocks, peripherals, etc. works well in the older version of CubeIDE (with older and compatible versions of CubeMX, X-CUBE- AI, MCUF7 package).

It's plain and simple project on STM32F7 without using any RTOS or other systems. I connect the board to the PC only to upload the code and to communicate with printf via USB.

Associate III

CubeIDE_1.5.0 works with my new Nucleo H743ZI2 and printf() too.