cancel
Showing results for 
Search instead for 
Did you mean: 

FDCAN Not working oh H755zi

macsdeve
Associate

Hello everyone,

I'm currently facing a puzzling issue with the Flexible Data-rate Controller Area Network (FDCAN) on the STM32H755ZI board. Despite using the exact same code that works flawlessly on the STM32H753 board, I am unable to get the FDCAN to function properly on the H755ZI.

Symptoms:

  • When setting the board in external loopback mode, everything seems fine. The mailbox fills up and behaves as expected, which indicates that the FDCAN module is internally operational.
  • However, when I move out of loopback mode to test actual CAN bus functionality using a logic analyzer or an oscilloscope, I observe no signals on the CAN_H or CAN_L lines. It's as if the board isn't transmitting any CAN signals at all.

Setup Details:

  • Board Used: STM32H755ZI
  • Environment: Standard setup with external transceivers connected to CAN_H and CAN_L.
  • Code Base: Identical code used on STM32H753 where FDCAN works without issues.

This behavior is quite baffling. The internal functions seem to work, but there's no physical output on the CAN bus lines. Has anyone else encountered a similar issue with the H755ZI or has insights into potential causes? Could there be a specific configuration or hardware issue unique to the H755ZI affecting FDCAN functionality?

I would greatly appreciate any insights, suggestions, or shared experiences that might help resolve this issue.

Thank you in advance for your assistance!

0 REPLIES 0