Showing results for 
Search instead for 
Did you mean: 

ST25R3916 discovery board, DFU not found and ST-link showed on device manager

Associate II


I started using the ST25R3916 discovery board and I have this error:
a ST-Link is detected instead of an "STM device on DFU mode"

I tried using the ST-link utility to make some test but I'm still not able to switch of device mode 
Now I am only connected with the USB port and the board's screen show the USB mode, only my PC doesn't recognise it correctly.

Is there someone who know how to resolve this issue ?


Antoine, from Kuvee


Accepted Solutions

Hi Antoine,

no idea, whatsoever. It is also the first time hearing that it does not work at all. 

Maybe an issue with the device detection in Windows such that the GUI does not get notified.... You could try first connecting the board and then open the GUI - AFAIK on startup of the GUI it will always try to connect. 

BR, Ulysses

View solution in original post

ST Employee

Seems to be the same issue as here.

Hope that helps?


In order to give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

Hey Peter,


Thanks for replying
Unfortunately I don't have this issue so it doesn't help me.
My board is not telling me to fix my firmware as I already updated it and it perfectly show me that it is in USB mode, but my PC can't find it.
In USB mode there is no device detected, but in ST-link mode it is perfectly detected.


Hi Antoine,

you need to plug the micro-USB to have PC comm mode operational!

Only it goes to STM32L4. The mini-USB just connects the ST-Linkv2.


Hey Ulysses

Thanks for replying,

As I said I already only plug the micro usb and the board is on the USB mode but the PC can't get the device

Hi Antoine,


well, in here you didn't even mention micro/mini. 

And having an ST_Link detected can only happen if you plug the mini-USB (labeled "STLINK USB"). The "MCU USB" does not connect to the ST-Link STM32F0.

You will only get the "STM device on DFU mode" if you perform firmware update. Otherwise it will just be another Human Interface Device.


BR, Ulysses 

Ok so to explain every step I done:

1) connect the mini and micro USB
2) Update the software from the ST-Link software
3) disconnect and reconnect through only micro USB
4) board showing USB mode
5) computer and ST25R3916 doesn't recognise any device


so I am currently blocked, as the device is not shown with the USB mode

Hi Antoine,

thanks, clear now about your steps.

When having Windows Device Manager open and plugging the board: Does the window refresh, or just stay static?

I am starting to suspect a HW issue. Can you check R5, R7 and L6 being populated. And also R8 not being populated? All on top layer - between Micro plug and Display?

BR, Ulysses

The window is refreshing when connecting the board but I didn't find any device with a name similar to what it should be.
Do you want me to send a screen of on of my device manager's section ?

Could you precise what are R5, R7, R8 and L6 ? I'm new to IoT so is this a therm for IoT only ?

Ok I just checked the board and it look fine as it should be, but I sent the photo just in case