STM32 MCUs products

cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

stm32f051 usart1

Posted on February 25, 2013 at 14:18 Hi, I'm switching from a stm32f100 to the stm32f051, most of the code is working already. but the usart1 does not work. The output doesn't change when I am trying to send something. Here are some snipp...

STM32f0 SPI trouble

Posted on February 24, 2013 at 02:04I am using the stm32f0 discovery board and having trouble getting SPI to talk properly with an external SPI sensor. As a test case, I wrote a small program to send bytes from SPI1 to SPI2 and then compare these se...

USART writes seem to block or slow down reads

Posted on February 09, 2013 at 15:35 I'm really stumped on this one, and hoping someone can help. I'm using USART_ReceiveData() to receive data off of a USB line at 9600 baud, on an STM32F0Discovery. It works without any trouble until I try to s...

STM32F051 USART Not working

Posted on February 01, 2013 at 00:39I created some simple code on the STM32F05-Discovery board to write a byte of data repeatedly out USART1.  However when I run this code on my target board the USART doesn't send the data.  The TXE line goes low an...

Library File - Hard Fault

Posted on January 28, 2013 at 18:58Hello All, I have recently started working with the STM32F0, and am trying to implement a PDM Microphone. In order to do this, I am using a library file provided by ST which has some functions for filtering PDM dat...

fraser by Associate
  • 266 Views
  • 2 replies
  • 0 kudos

STM32 M0/M3 simulation

Posted on January 11, 2013 at 10:40I tried to revive an older thread, but that seems not possible if it dates back before the last database meltdown ... Is there any simulation of STM32 MCUs available, specifically the F0 and F1 ? And I don't mean t...

STM32F0 discovery example on Coocox

Posted on January 21, 2013 at 11:30Hello, I newly started working with the stm32f0 discovery board on Coocox. I have downloaded the examples from ST but it doesnt compile. It seems that the linker doesnt find the definition of some types, even if I ...