STM32 MCUs products

cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

STM32F4Discovery i2c using

Posted on January 22, 2013 at 12:39I need to use I2C1 ports for communication with LG3D20(0xD6 adress) gyro sensor.Accordingly, i need i2c1 initial,i2c1 write data 1 byte,i2c1 read data 1 byte functions.I am using these functions but i couldnt run t...

i2c using std periph library

Posted on February 13, 2012 at 18:12Hi. Anyone has a complete example of use of the i2c protocol (in master and slave mode) for the STM32F4 using the std periph library? the examples included in the library are very confusing, I want an example for ...

STM32 IIC EEPROM Example

Posted on December 14, 2012 at 15:45helloI'm new in programming STM32 cardsI ask for your help. I try to use the example of IIC EEPROM on a map STM32 VL-Discovery.IAR tells me errors when building. the errors are in the main.cit does not recognize t...

mhamdi by Associate
  • 69 Views
  • 1 replies
  • 0 kudos

STM32F4 I2C BTF bit is not set after DMA TX complete

Posted on December 10, 2012 at 18:29Hi all,I noticed that there is an high traffic in I2C2_EV_IRQHandler() with status 0x70080 (EV8 =I2C_EVENT_MASTER_BYTE_TRANSMITTING) after all the bytes was transmitted with success by DMA (but it's the same probl...

neoirto by Associate II
  • 135 Views
  • 2 replies
  • 0 kudos

STM32L152 - i2c interupt not firing

Posted on November 30, 2012 at 02:22 Hi there, I am wondering if anyone could help me on a small issue. My I2C1_EV_IRQHandler is not firing when I2C_GenerateSTART(I2C1, ENABLE); is called. Can anyone see anything in the below set...

STM32 + I2C

Posted on December 04, 2012 at 13:12 Hi all, I am using STm32f2 series and I have a sensor on I2C bus. The problem is that my I2C bus is always busy. My code: void setupClock() { RCC_DeInit (); RCC_HSEConfig (RCC_HSE_ON); while (...

I2C read() strange status register in SR2

Posted on November 01, 2012 at 17:32 Hi all, I have a problem on my I2C2 configuration on STM32F4. I try in poll mode first, and I have strange result : write() seems to be ok, but not read() (see comments in code below) : uint8_t data...

neoirto by Associate II
  • 181 Views
  • 7 replies
  • 0 kudos