STM32 MCUs products

Showing results for 
Search instead for 
Did you mean: 

Forum Posts

Resolved! RCC configuration results in HardFault (STM32F411CEU6).

I have a board that is running well. There are about 50+ PCBs in production operating fine. The firmware is pretty complex, but the hardware relatively simple, just some SPI devices and some PWM outputs.I revved the board, and the new board doesn't w...

YvanR by Associate II
  • 3 replies
  • 0 kudos

I have a array declared as: char* arrs[20][30]; I have filled up this array with name and value and now I must compare for example, the first element of arrs [] value and the third element of arrs[] value. How can I do this?

I have tried to use strcmp and have also tried (arrs[0] == arrj[1][8]) with no luck. My goal is to check if the corresponding values are equal. (for reference: arrs[0] = freq :100kHz and arrj[1] = freq: 100kHz). I just wanted to see the values are e...

cjaya.2 by Associate II
  • 1 replies
  • 0 kudos

The DMA transfer only the first byte from ADC1 (STM32H735)

I configure the ADC1 of the STM32H735 like bellow:The ADC Clock = 20MHzADC_HandleTypeDef hadc1; DMA_HandleTypeDef hdma_adc1;   /* ADC1 init function */ void MX_ADC1_Init(void) {   /* USER CODE BEGIN ADC1_Init 0 */   /* USER CODE END ADC1_Init 0 *...

_legacyfs_online_stmicro_images_0693W00000biUC8QAM.png _legacyfs_online_stmicro_images_0693W00000biUKvQAM.png
Saif by Associate II
  • 21 replies
  • 0 kudos

STM32H7 LSE Hardfault

I'm using external crystal for RTC on STM32H750VB. Sometimes when i powered up to board, its hanging on LSE initialization and entering hard fault. If i remove rtc backup battery and plug it again, its working. This happens very rarely :S I couldn't ...

Eralp by Associate II
  • 4 replies
  • 0 kudos

Nucleo STM32L552 w/ext JTAG

HiI'm using a Nucleo STM32L552 an want to use my segger JTAG; I've wired CN5 on the dev board to my JLINK (with the exception of pin 1 for VDD; I hooked that directly to the 3.3V pin in the arduino header) and I'm not able to connect my device to the...

CChoc.1 by Associate
  • 0 replies
  • 0 kudos

Resolved! Does the STM32G070CBT6 have a Unique ID?

In spite to the reference manual of the STM32G071CBT6 the unique ID is not described in the reference manual of the STM32G0x0 series, but its address is defined in the header file (stm32g070xx.h).Now I wonder if it is missing in the reference manual ...

stst9191 by Associate II
  • 4 replies
  • 0 kudos