STM32 MCUs Wireless

cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

Resolved! WB55 Nucleo Board + I-NUCLEO-CN0216 Adapter on SPI 1

Hi Everybody!I'm trying to prototype a force measure application with SD-card on a P-NUCLEO-WB55 Board and I-NUCLEO-CN0216. I'm using the latest CubeIDE.The SD Card work perfectly both on SPI 1 and SPI 2(In my project i'm using SPI 2 for the differen...

Hunhazy by Associate
  • 272 Views
  • 3 replies
  • 0 kudos

Resolved! Bare metal SPI DMA initialization problem on STM32WLE5

Hi all, I'm trying to implement SPI TX communication with DMA. The following "prepareDMASPI()" function should configure and start DMA transferts from a buffer to the SPI device. But it doesn't work (No spi clock or MOSI data), although the SPI is pr...

OFauc.1 by Associate II
  • 209 Views
  • 2 replies
  • 1 kudos

How to use RGB LED in STM32WB5MMG-DK?

/*SPI Initialization*/ static void MX_SPI1_Init(void) {   /* SPI1 parameter configuration*/ hspi1.Instance = SPI1; hspi1.Init.Mode = SPI_MODE_MASTER; hspi1.Init.Direction = SPI_DIRECTION_2LINES;//SPI_DIRECTION_2LINES; hspi1.Init.DataSize = ...

PB S.1 by Associate II
  • 215 Views
  • 1 replies
  • 0 kudos

STM32WB55 nucleo board SPI clock not working

Hello. I am trying to setup SPI1 on the STM32WB55 nucleo board. I have setup the nucleo board with the default peripheral configuration using STM32CUBEMX and I have enabled SPI1 Transmit Only Master mode: In my code, all I am trying to do is SPI1 tra...

0693W00000D0iYdQAJ.png 0693W00000D0iZMQAZ.png
LPetr.1 by Senior
  • 365 Views
  • 5 replies
  • 0 kudos

SPI reset on STM32WB55

HelloI am using an STM32WB55. This microcontroller communicates in SPI with a second STM32F4 micrcontroller.The STM32WB55 is slave and the STM32F4 is the master of communication.During an electrostatic discharge, the SPI communication is disturbed.Th...