Other tools (MCUs)

cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

Log Data externally with STM32F767ZI and Simulink

Hey everyone,I want to use a STM32F767ZI to develop driving safety functions for electric scooters.The functions and Code are developed on Simulink using the Support Package for nucleo boards. I would like to log data from the MCU directly to a SD-Ca...

LKlau.1 by Associate
  • 481 Views
  • 3 replies
  • 1 kudos

Hi All STM32 users, has anyone successfully done any debugging using VSCode with all the relevant packages installed along with the ST-LINK/V2 probe on Linux?

I have all the relevant ARM utils/etc on the system.As soon as I try to run, I get this message-"Could not start GDB process, does the program exist in filesystem?"Tried jumping through hoops for last few days but getting no where.Tried with all kind...

WTAYL.1 by Associate
  • 443 Views
  • 3 replies
  • 0 kudos

Problems sending SPI Data from STM32 to arduino

I'm trying to learn how to communicate via SPI with STM32 but I've run into some problems.The first step i took was to implement SPI communications using two arduino unos: the master writes a byte and the slave responds with another byte according to...

0693W00000WINJ5QAP.png
HPont.2 by Associate
  • 332 Views
  • 0 replies
  • 0 kudos

DfuSe Demo v3.0.6 doesn't flash stm32f722ret6

I was trying to flash stm32f722ret6 via DFU mode. DfuSe Demo typing successful status but firmware doesn't update.But when I download .hex file via ST-LINK a firmware works. What could be the problem?

0693W00000QNm4kQAD.jpg 0693W00000QNm59QAD.jpg
ab.2 by Associate II
  • 744 Views
  • 11 replies
  • 0 kudos

Problem with Single Step STMF7

Posted on December 07, 2016 at 21:47 There is a problem with IDE debuggers for STMF7, and as I understand, all ARM M7 core based processors. With other CORTEX controllers, when a debbuger pauses or hits a breakpoint, the debugger stops interrupt pr...

STM32 QSPI works with compiler Version 5 but not 6

I'm not sure if it's more appropriate to post this in the ARM/Keil forum or the STM32 forum so I'm trying both.We have a project based on an STM32F730V8Tx and I need to use the QSPI block. We created a simple test project that just initializes the ex...

EGers by Associate
  • 168 Views
  • 0 replies
  • 0 kudos