Other tools (MCUs)

cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

RTC Alarm not working on stm32duino

Hi, pls help, I have rtc working, counting seconds, but I didn't succeded to make alarm work.// the setup function runs once when you press reset or power the boardvoid setup() { delay(500); RTC_init(HOUR_FORMAT_24, LSI_CLOCK, 1); //RTC_SetClockSourc...

IDine.1 by Associate
  • 368 Views
  • 1 replies
  • 0 kudos

HAL i2c & SPI initialization help needed

Hi.I'm using PlatformIO with stm32duino with a NUCLEO-L476RG. I finally figured out how to configure the clocks in CubeMX and then copy the "void SystemClock_Config(void)" function into my main.cpp code and it seems to work great.One question I have ...

YGagn.1 by Associate
  • 262 Views
  • 1 replies
  • 0 kudos

CAN Bus between STM32F103 and Arduino

I have a few arduino boards communicating through each other on a CAN Bus. Arduino is connected to a MCP2515 CAN Bus Module TJA1050.All arduino are communicating properly between each other. Here is an example of my reader on arduino:#include "MIDIUS...

Resolved! NUCLEO-G474re Arduino I2C not working.

I'm trying to do a quick eval of a NUCLEO-G474re board for use of the SoC as a product communication controller (I2C, SPI, RS-485, etc.), initially using the Arduino environment for rapid testing. Initial attempt to bring up I2C causes NO activity on...

BCunn.1 by Associate
  • 940 Views
  • 1 replies
  • 0 kudos

Problems sending SPI Data from STM32 to arduino

I'm trying to learn how to communicate via SPI with STM32 but I've run into some problems.The first step i took was to implement SPI communications using two arduino unos: the master writes a byte and the slave responds with another byte according to...

0693W00000WINJ5QAP.png
HPont.2 by Associate
  • 366 Views
  • 0 replies
  • 0 kudos